[arch-dev-public] Updating gcc3 package

Paul Mattal paul at mattal.com
Wed Jun 20 08:08:59 EDT 2007

Jan de Groot wrote:
> Think about this:
> Gcc 4.x is on the same ABI as gcc 3.4, there's lots of file conflicts in
> that and you'll end up using gcc 4.2 libraries with a gcc 3.4 compiler. Gcc
> 3.3 is the last released version of the previous C++ ABI and is still
> maintained AFAIK. A package that requires gcc 3.4 to compile (nothing newer,
> nothing older) is so broken that upstream should fix it, we shouldn't even
> bother about it. Even OpenOffice.org got this point improved in the last two
> years.

I agree with Jan that it sounds like this should be fixed upstream
quickly, however it might not be that much work to take from the gcc and
gcc3 packages to make a separate gcc34 package for the short term.

- P

More information about the arch-dev-public mailing list