[arch-dev-public] Migration to QT4

Eric Belanger belanger at ASTRO.UMontreal.CA
Mon Nov 5 23:05:17 EST 2007

On Sun, 4 Nov 2007, Pierre Schmitz wrote:

> Hi all,
> as I mentioned some time ago I want to move qt4 to [extra] soon. I am quite
> busy right now; so there is some delay but I am still working on this.
> Before committing my changes to [testing] I want to discuss the upgrade path
> again. (because it will be some work to revert this changes if it was a bad
> idea after all)
> qt and qt-docs will be updated to version 4. They will replace the packages
> from community and provide qt4 as well. Like the community package they will
> be installed into /usr instead of /opt. We do not need any script
> in /etc/profile.d then.
> Version 3 of qt will be packaged as qt3 and qt3-docs. It will stay in /opt and
> still will have a profile script; but it will be disabled per default. All
> packages directly depending on qt version 3 will be repackaged to depend on
> qt3. The PKGBUILD have to source the profile.
> Packages like KDE and others depending on kdelibs do not need to be rebuilt.
> Pierre

In the previous discussions, it was suggested to split qt4 into 3 
packages: qt4core qt4-x11 and qt4qt3support
Is it still the case?  From the above upgrade path, it doesn't seem so.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the arch-dev-public mailing list