[arch-dev-public] PyQT4?

Pierre Schmitz pierre at archlinux.de
Sat Nov 17 15:23:02 EST 2007

Am Donnerstag, 15. November 2007 02:35:26 schrieb Damir Perisa:
> any schedule for pyqt? this weekend i'm probably offline because of a
> dancing festival (tango).

OK, this does not seem to be straight forward. So I need some feedback from 
the maintainers of the following packages. (They somehow depend on each 

	I wanted to introduce the old package as poppler-qt3 and 
	update poppler-qt to use qt-4. However: 
	it does not compile against qt-4 when the bindings-patch is applied.

	should be updated to 4.3.1. The old version would be renamed to pyqt3 for
	consistency. The problem: it depends on qscintilla which uses qt3 atm.

	This package confuses me. The provide a QScintilla-1.73-gpl-2.1.tar.gz and
	QScintilla-1.71-gpl-1.7.1.tar.gz (which we currently use). According to their 
	homepage "QScintilla v2 supports both Qt v3 and Qt v4".
	Is there an easy way to provide two non conflicting packages for qt3 and 
	qt-4? Is it usefull to introduce a common packge which includes those files
	which are shared by the qt3 andqt-4 version?



More information about the arch-dev-public mailing list