[arch-dev-public] Problem with x86_64 repo and db

Eric Belanger belanger at ASTRO.UMontreal.CA
Sat Apr 12 12:19:52 EDT 2008


There some problem with the extra x86_64 repo. Acording to the db, the bzr 
and  graphviz packages are at versions: bzr-1.3-1.1 and graphviz-2.16.1-3. 
But the versions of the packages on the server and
  which get installed are: bzr-1.3-1 and graphviz-2.18-2

Can someone with more experience with svn or the db fix that? I can file a 
bug report if needed.

I also tried to update darcs for x86_64 but there's a svn conflict:

$ extrapkg
100% 1214KB   1.2MB/s   00:00
File integrity okay.
===> Uploaded darcs-2.0.0-1-x86_64.pkg.tar.gz
===> Commited with "upgpkg: darcs 2.0.0-1" message
C    ../repos/extra-x86_64/PKGBUILD

property 'svnmerge-integrated' set on '../repos/extra-x86_64'

~/svnroot/darcs ~/svnroot/darcs/trunk
svn: Commit failed (details follow):
svn: Aborting commit: 
'/home/eric/svnroot/darcs/repos/extra-x86_64/PKGBUILD' remains in conflict
===> Tagged for extra-x86_64

$ diff /home/eric/svnroot/darcs/repos/extra-x86_64/PKGBUILD PKGBUILD
< # $Id: PKGBUILD,v 1.10 2007/06/23 16:56:02 pierre Exp $
> # $Id: PKGBUILD,v 1.9 2007/06/18 16:26:45 dan Exp $
< <<<<<<< .working
< md5sums=('077420eec437ecdd45d8dc6682ee61fa')
< =======
< >>>>>>> .merge-right.r11

I also tried to update pidgin for x86_64 but it says thayt there is 
nothing to commit:

  $ extrapkg
100% 8821KB  94.9KB/s   01:33
File integrity okay.
===> Uploaded pidgin-2.4.1-1-x86_64.pkg.tar.gz
===> Commited with "upgpkg: pidgin 2.4.1-1" message
~/svnroot/pidgin ~/svnroot/pidgin/trunk
Nothing to commit
===> Tagged for extra-x86_64

The package was still uploaded to gerold and I ran the db script but the 
package isn't in the repo.

I did successfully updated netpbm and devtools so I don't know why the 
packages above failed.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the arch-dev-public mailing list