[arch-dev-public] The move to SVN

Eric Belanger belanger at ASTRO.UMontreal.CA
Mon Apr 14 22:40:37 EDT 2008

On Tue, 8 Apr 2008, Jason Chu wrote:

> On Tue, Apr 08, 2008 at 09:04:44PM +0200, Pierre Schmitz wrote:
>> Am Dienstag, 8. April 2008 20:44:38 schrieb Aaron Griffin:
>>> There was a question about moving something from testing to extra.
>>> Originally, the package was submitted with "testingpkg" which creates
>>> pkgname/repos/testing-$arch and uploads. Now, to release to extra, we
>>> run extrapkg to create pkgname/repos/extra-$arch and upload. Easy as
>>> pie.
>>> Removing from testing would be as simple as:
>>> svn rm -f pkgname/repos/testing-$arch
>>> Now.... head's up: I will be partially implementing the move on the
>>> dbscripts side. That is, if a package being uploaded to extra is in
>>> testing, it will do all the removal from the DB and that fun stuff...
>>> I don't know if I will remove it from svn or not, but I always
>>> could...
>> No idea if I got this right, but this way we have to upload the package twice?
>> (OK, if this is the case I could update my testing2extra script which runs on
>> gerolde anyway; so in fact it would be a local copy)
> Oh, I see what you're saying.  I'll make an amendment to Aaron's comment.
> If you're moving a package from testing to extra, usually an "archrelease
> extra" is all you need from the trunk directory.  You do *not* need to
> upload the package again.
> Jason

I tried to move bmpx from testing to extra but it doesn't work.  First, 
the '-f' switch doesn't it's '--force'. I ran 'archrelease extra' in the 
trunk directory then did the package move  and db-script on gerolde but it 
only removed the testing package. The  package in extra is still at the 
old version. It seems that the command should be 'archrelease 
extra-$arch'. Is that correct? I tried that then ran the db-script after copying the package to my staging 
dir but it doesn't work.  Can someone fix this and clarify the process?

I also tried to update firefox3 for unstable x86_64. When running 
unstablepkg I got:
$ unstablepkg
100%   11MB  91.1KB/s   02:03
File integrity okay.
===> Uploaded firefox3-3.0b5-1-x86_64.pkg.tar.gz
===> Commited with "upgpkg: firefox3 3.0b5-1" message
~/svnroot/firefox3 ~/svnroot/firefox3/trunk
Nothing to commit
===> Tagged for unstable-x86_64

The package was uploaded to my staging directory and I ran the db script. 
>From the output there was no error but the package is not in the repo. 
This has happened a couple of time. Am I trying to update packages that 
have already been uploaded to another dev staging dir? Or is there another 


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the arch-dev-public mailing list