[arch-dev-public] Xorg-server 1.5RC6 enters testing

Xavier shiningxc at gmail.com
Sun Aug 31 19:07:03 EDT 2008

On Sun, Aug 31, 2008 at 8:37 PM, Jan de Groot <jan at jgc.homeip.net> wrote:
> Xorg-server 1.5RC6 ( enters tesing. This version of
> xorg-server includes input hotplugging using hal, better EXA support and
> less memory usage.
> Note that this version requires an upgrade of all videodrivers.
> All videodrivers shipped with X.Org have been rebuilt to reflect this
> change. Nvidia drivers don't seem to need a rebuild, while AMD's
> catalyst drivers don't support the new X.Org version. Fglrx users should
> not upgrade to this version.
> Please give this version of X.Org an extensive test run and report bugs.

I don't think any of the following are really bugs, at least they
didn't cause me any troubles, so I am just giving feedbacks here.

1) As reported in FS#11357, Xorg failed to start because of RgbPath
option which is no longer valid.
And this is the main change I saw when I generated a new config with
Xorg -configure.

2) I did not have evdev installed initially, and my keyboard settings
worked fine. I saw a lot of warnings in Xorg.0.log about evdev missing
so I tried to install it.
After that, it seems my keyboard and mouse section in xorg.conf are
ignored, it apparently uses evdev by default.
I simply picked the keyboard layout in gnome gui, but I am not sure
how it selects it, is it equivalent to setxkbmap?
Otherwise the right way to configure it is to edit some hal config file?

3) I am using the intel driver and get a strange warning when running
glxinfo or glxgears :
Failed to initialize TTM buffer manager.  Falling back to classic.
And glxgears seems pretty slow.
But I tried an opengl game (bzflags), and it ran amazingly well. I am
pretty sure it ran much better than last time I tried.

I found a report about the same TTM message, except I did not see any crash :

4) also some new scary intel warnings in the log (repeated twice) :
(WW) intel(0): ESR is 0x00000001, instruction error
(WW) intel(0): Existing errors found in hardware state.

More information about the arch-dev-public mailing list