[arch-dev-public] current e2fsprogs incompatible with grub

Xavier shiningxc at gmail.com
Sat Feb 9 06:10:40 EST 2008

Thomas Bächler wrote:
> I checked the patch into CVS. If it is okay, I can rebuild grub with
> this patch and check it into testing. Opinions?

I tested it now, and it looks ok.
I was still be able to boot my current ext2 partition, inode size 128 
with it.
Then I built a ext3 partition, inode size 256, and grub-install still 
worked fine. Same for reboot.

Note that I am using a small boot partition (39M) and /etc/mke2fs.conf 
has a "small" fs type section, where inode size is still set to 128.
So I had to edit that config file to get 256, otherwise I would not have 
been affected by the problem.

When I tried to run grub-install without the patch on that /boot 
partition, I got the following message :
The file /boot/grub/stage1 not read correctly.

So well, even if the grub patch is not applied, and someone tries to run 
grub-install with 256 inode size, it's at least clear that something 
goes wrong (even if it doesn't say what is wrong).

Otherwise, the problem only appears when using grub-install. I suppose 
that's not a command that people run every day. It's probably more 
frequently used when installing from an iso.

But to sum up, I have nothing against this patch, since it at least 
seems to work fine on my laptop (686).

More information about the arch-dev-public mailing list