[arch-dev-public] [signoff] initscripts 2008.02-1

Jeff Mickey jeff at archlinux.org
Fri Feb 22 12:46:47 EST 2008

As we noticed from the filesystem thread ( I rule ) that I tested the
initscripts out this morning.

I ran into a lot of retarded problems for simple reasons, udev 118-2
should depend on the new initscripts and the new initscripts should
depend on netcfg.  Let's watch what happened!

# pacman -Syu # updated to new [testing]

% ping google.com # no response!
% sudo /etc/rc.d/network restart # restarts, but doesn't ask for the menu?
% vim /etc/rc.conf /etc/rc.conf.pacnew # rename the variable correctly
% sudo /etc/rc.d/network restart # restarts, but still doesn't ask for the menu?
% sudo pacman -U /var/cache/pacman/pkg/initscripts-2007.11-2-i686.pkg.tar.gz
% sudo /etc/rc.d/network restart # asks menu, connects, yippie kay-yay!
 <.. > computer use
% reboot

Bad superblock on /dev/sda4? bad superblock on /dev/sda2?
# ls /dev
console null zero

Udev didn't restart correctly because I was running the old
initscripts with the new udev, and the new udev gets rid of
/etc/start_udev (which is fine) except that the new udev REQUIRES the
new initscripts to work.

Get on the phone with Aaron, he helps me figure this hoopla out.

pacman -S initscripts netcfg

And now were at the present and me writing this email.  Add the netcfg
dependency to initscripts, and the initscripts>=2008.02-1 to udev 118,
and I'm happy.

    //  jeff
. : [ + carpe diem totus tuus + ] : .

More information about the arch-dev-public mailing list