[arch-dev-public] Moving the DB scripts

Aaron Griffin aaronmgriffin at gmail.com
Thu May 22 12:56:51 EDT 2008

On Thu, May 22, 2008 at 11:03 AM, Aaron Griffin <aaronmgriffin at gmail.com> wrote:
> On Thu, May 22, 2008 at 10:30 AM, Eric Belanger
> <belanger at astro.umontreal.ca> wrote:
>> On Tue, 20 May 2008, Aaron Griffin wrote:
>>> On Tue, May 20, 2008 at 11:36 PM, Eric Belanger
>>> <belanger at astro.umontreal.ca> wrote:
>>>> On Tue, 20 May 2008, Aaron Griffin wrote:
>>>>> Hey all,
>>>>> I'm going to move the new db scripts live. In an hour or so. I still
>>>>> need to generalize Pierre's testing2core script and commit it, then I
>>>>> will push them live.
>>>>> Once I do that, it is going to break the website updates for a short
>>>>> period - until Eliott can get to the web changes (we haven't been able
>>>>> to coordinate properly, so rather than wasting time, I'm doing this
>>>>> move now).
>>>>> So, if you guys could hold off doing repo related activities in about
>>>>> an hour or so, that'd be great.
>>>>> One fun addition: /arch/db-remove
>>>>> No more need for package files to remove a package. Syntax is:
>>>>> db-remove pkgname repo arch
>>>>> Cheers,
>>>>> Aaron
>>>> Status update:
>>>> Aaron just contacted me via Jabber. Due to time constraint as it's
>>>> becoming
>>>> late, the move will happen tomorrow.
>>> Thanks Eric. Additionally, I added 'db-move' which is a generalization
>>> of Pierre's testing2extra script. db-move, testing2extra, and
>>> testing2core are all in /arch-new if you want to test them.
>> I tried to use testing2core but it didn't work. It's the first time I use a
>> script to do that so I might be doing it wrong. First, I did the usual
>> archrelease stuff locally. Then I logged on gerolde and:
>> $ /arch/testing2core licenses bzip2
>> ==> Moving package 'licenses'
>> Checked out revision 1848.
>> Error: licenses is not in repo testing
>> ==> Moving package 'bzip2'
>> Checked out revision 1848.
>> Error: bzip2 is not in repo testing
>> Did I had to copy the packages in the staging directories before? Or is it
>> something else? I eventually did it manually and that worked.
> Ah, yeah - those scripts mean you don't have to do anything locally.
> If it's in testing, just connect to gerolde and run "testing2core"
> It's only one step.
>> Also, I noticed that the new db script no longer removes the files in the
>> staging/${repo}64/* directories. I know it'll be a moot issues when the
>> devtools package will be updated but, instead of copying the packages to
>> staging/${repo}/*, can't it just move them there? Of course, if devtools is
>> planned to be updated soon then you can ignore this request.
> Ah yeah, I overlooked that. Right now I copy files from the *64 dirs
> to the non-suffixed ones. I guess I could 'mv' them to cover all the
> bases

Updated the scripts:
   fixed db-remove usage output
   use 'mv' to transfer from staging64

More information about the arch-dev-public mailing list