[arch-dev-public] [signoff] wpa_supplicant 0.6.8-1

Thomas Bächler thomas at archlinux.org
Sat Feb 28 15:06:30 EST 2009

Thomas Bächler schrieb:
> wpa_supplicant declared the 0.6 branch as stable, changes compared to 
> the old version are:
> - Disabled prism54, hostap, madwifi and IPW drivers, these should all be 
> obsolete and work with the "wext" driver. If any problems occur, I can 
> enable them again, but I think having only wext is enough.
> - Enabled the new nl80211 driver. This has additional features over the 
> wext driver, like setting the country code (this driver currently only 
> works with compat-wireless or maybe 2.6.29 release candidates)
> - Enabled readline support for wpa_cli
> - Enabled WPS (WiFi protected setup), I don't know if anyone really 
> wants that, but it is there now.
> wpa_supplicant_gui has also been considerably improved.
> Please sign off.

Pierre noted that this version removes the "-w" option and thus breaks 
netcfg. We need to patch netcfg to not use the -w option. James, can you 
put an updated version to testing?

I also noticed I accidently built this with support for "atmel" and 
"ndiswrapper" drivers, which are probably also obsolete. The wext driver 
should at least cover ndiswrapper support.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 260 bytes
Desc: OpenPGP digital signature
URL: <http://www.archlinux.org/pipermail/arch-dev-public/attachments/20090228/38c905d6/attachment.pgp>

More information about the arch-dev-public mailing list