[arch-dev-public] Warning: libldap and postgresql rebuilds entering [testing]

Jan de Groot jan at jgc.homeip.net
Sat Sep 19 07:58:54 EDT 2009

On Sat, 2009-09-19 at 12:45 +1000, Allan McRae wrote:
> libldap and postgresql rebuild status for [core] and [extra]:
> The following packages are all that remain to be rebuilt but have some 
> issues...
> evolution
>   checking if pilot-link handles UTF-8 conversions... no
>   configure: error: evolution requires pilot-link to have working UTF-8 
> conversion routines
> evolution-exchange (requires evolution makedepends)
> redland
>   ./configure: line 14475: syntax error near unexpected token `1.3'
>   ./configure: line 14475: `GTK_DOC_CHECK(1.3)'
> seahorse (i686 only)
>   In file included from seahorse-gpg-op.c:23:
>   /usr/include/gpgme.h:80:2: error: #error GPGME was compiled with 
>     please see the section "Largefile support (LFS)" in the GPGME manual.
> It would be good if their respective maintainers can look into the issues.
> Allan

Evolution and friends aren't -Wl,--as-needed safe, so recompiling
without those flags should work out. I haven't noticed anything in
pilot-link with 2.27.92.

Redland: needs gtk-doc makedepends
Seahorse: needs patches, check the gnome-unstable packages for this,
they're in svn.

More information about the arch-dev-public mailing list