[arch-dev-public] CUPS backend for both libusb-based and usblp-based access

Andreas Radke a.radke at arcor.de
Mon Apr 26 18:48:42 CEST 2010

I know users with multidevices have a serious problems with recent 1.4.0
update because they can only use either the scanner or the printer.

I've just found this patch from Till Kapeter, the main
OpenPrinting(foomatic) developer and Debian cups package maintainer.


I assume this could solve all outstanding issues. But sure this is not
the current upstream way. And I cannot test it in any way because I
don't have such a device.

This is to show affected users a possible way to recompile our cups
packages with this patch. 

If it really solves the trouble we might think if it should be done
manually (we could put the patch into svn though). That would
receive my vote.

Or if we could trust Debian here and provide stuff that is not the
upstream way but - if proved - solves all the trouble. I couldn't
provide any help but doing building the packages.

Please test the patch and post your opinions.



More information about the arch-dev-public mailing list