[arch-dev-public] kde 4.5.0

Ronald van Haren pressh at gmail.com
Thu Aug 19 09:35:51 EDT 2010

On Wed, Aug 18, 2010 at 5:43 PM, Ronald van Haren <pressh at gmail.com> wrote:
> On Wed, Aug 18, 2010 at 1:42 PM, Thomas Bächler <thomas at archlinux.org> wrote:
>>>> 2) dolphin segfaults. A lot. All the time. It's annoying.
>>> I know this happened on the 4.5 release candidates when tooltips or
>>> the information panel were enabled. The fix should have been included
>>> in the latest set of source tarballs, but can you test nevertheless if
>>> disabling those fixes it?
>> The information panel is always active in my settings, don't know which
>> tooltips you are talking about. And I didn't experience dolphin crashes
>> in the rc's.
> you can enable tooltips in dolphin via settings->configure
> dolphin->general-> tooltips, it will show the same info as in the
> information panel when hovering an icon. I enabled both earlier today
> on my system but I still haven't had a single crash, so it doesn't
> seem the bug I mentioned which I was able to trigger quite a lot.
>> Another thing I noticed: Whenever I navigate to audiocd:/ and copy the
>> MP3 folder, dolphin crashes and doesn't start the copy. When I do it
>> again, it works.
> works fine here. I should note that I have created a new profile, even
> after the release candidates.  I know that normally the old configs
> should still work but there have been a lot of cases where crashes
> happened because of it, one time even some settings in the ~/.config
> directory caused instability.
> I've been looking on the KDE bug tracker but couldn't find anything
> related to any of your described dolphin problems. If the problem
> persists with a clean config/new user, can you provide some more info
> to go on.
> Do any other people running kde 4.5.0 experience such instability in
> dolphin (feel free to contact me off-list if you don't have access
> here so maybe we can solve this) ? I don't really want to push it into
> extra if a lot of people have problems with the filemanager.
> Ronald

I did some more digging and found the bug you are probably
experiencing [1]. There are quite a few duplicates, also some from
Arch users. It all comes down to a very old dbus bug. There is a patch
available for it [2] but I'm not sure that it fixes the issue complete
(please try, I think it is the same patch as dbus-core-mt in AUR has).
Upstream has only applied the patch to the upcoming 1.3 unstable
branch, so the next stable dbus release which fixed the dolphin
instability is 1.4.

So we have unstable graphical drivers and an old 2008 dbus bug which
makes kde unstable...how nice.

Thomas and other people who have an unstable dolphin, please see if
that is the issue and see if the patch works.

Jan any chance we can make the jump to dbus 1.3.2 or alternatively
incorporate the patch linked if that works?


[1] https://bugs.kde.org/show_bug.cgi?id=208921
[2] http://lists.freedesktop.org/archives/dbus/2008-January/009100.html

More information about the arch-dev-public mailing list