[arch-dev-public] KDE 4.6 RC1

Andrea Scarpino andrea at archlinux.org
Thu Dec 23 12:39:04 EST 2010

Hi all,
KDE 4.5.90 packages are available in [kde-unstable].

The new KDE series provides a new backend for power management (Upower) and 
for disk management (Udisks); before, we only had the HAL backend. Now kdelibs 
4.5.90 depends on both those packages thus you can remove hal from your system 
and from the daemons to run at start (you have to replace it with dbus).

Note: Some system could lose the sounds removing HAL; changing the phonon 
backend or use pulseaudio could help in that case.

Upstream decided to skip the 4.6.0 release for kdepim, but they released a 
beta3 which is available in [kde-unstable] too. We have to wait kdepim 4.6.1 
for a stable KMail2.
Anyway, KDE 4.6 is compatible with kdepim 4.4.9 which is already in [extra].

Arch Linux packages changes:
- filelight is replaced by kdeutils-filelight
- kdeutils-okteta is replaced by kdesdk-okteta
- kdegames-ksame is replaced by kdegames-klickety
- kdesdk-kbugbuster has been removed (upstream)
- a new runner for krunner is available in kdeplasma-addons-runners-events
- a new kdeplasma-addons-containments package introduces the GroupingDesktop

Be careful updating: do a backup of your ~/.kde4 dir.
See the list[1] of the packages which do not work with KDE 4.6 and read the 
known issues[2] too.

Also, follow the forum thread[3].

[2] https://wiki.archlinux.org/index.php/DeveloperWiki:KDE#Known_issues
[3] https://bbs.archlinux.org/viewtopic.php?id=109002

Andrea Scarpino
Arch Linux Developer

More information about the arch-dev-public mailing list