[arch-dev-public] [HEADSUP] Minimum kernel version bump

Tom Gundersen teg at jklm.no
Mon Jan 2 09:28:43 EST 2012

Hi guys,

A quick update:

On Thu, Dec 29, 2011 at 11:54 AM, Tom Gundersen <teg at jklm.no> wrote:
> The next udev release will change its kernel requirements.


>  * 2.6.34 is the minimum kernel requirement (our current -lts is .32).

As far as I can tell this is not really relevant to us, and we should
not expect any great problems from sticking with .32.

I'll fix some minor issues I found (lacking static device nodes) when
I push the next udev-compat release. When that is done, the only
outstanding issue is the udev rules. The upstream rules are kept
up-to-date with the latest kernel release and rules are removed when
they are no longer needed. We might want to review the changes to the
rules since udev-149, to check if there are any rules that have been
changed/removed that we want to add back in. Preferably any additions
we make should go upstream in "rules/misc/30-kernel-compat.rules".

I'll still write a news item regarding the removal of devtmpfs
support, but it seems that there is no reason to worry about .32



More information about the arch-dev-public mailing list