[arch-dev-public] udev-177

Andrea Scarpino andrea at archlinux.org
Fri Jan 13 07:40:38 EST 2012

On 13 January 2012 12:39, Tom Gundersen <teg at jklm.no> wrote:
> Any change we could narrow this down a bit? If you upgrade again
> kmod+mkinitcpio (possibly ignoring the versioned deps), do you still
> get the bug? I assume udev is the culprit, so would be nice to get a
> confirmation.
I updated kmod,mkinitcpio,systemd (except udev then) and everything's fine.

> When you say that wifi was broken, do you mean at the kerne/modules
> level, or at the NM level? I.e. is it possible to get the wifi working
> using commandline tools, or even nm-cli as root?
I was broken at kernel level, I just found this (this is the output
using udev 177):

[   10.732916] Loading firmware rtlwifi/rtl8192sefw.bin
[   71.520133] rtl8192se:rtl92s_init_sw_vars():<0-0> Failed to request firmware!
[   71.520141] rtlwifi:rtl_pci_probe():<0-0> Can't init_sw_vars.

> Any more details / logs about the applications not starting? E.g.
> which applications are not starting?
Forgot that.

>> This error has gone after the downgrade: http://dpaste.com/687105/
> Hm, so the NM related ones are surely caused by CK failing to start.
> No idea why CK is failing though (I have tested CK+sd+[testing] and it
> works fine for me). Does 'systemctl status console-kit-daemon.service'
> give you any more info?
As I said, everything's ok without udev 177 now. The console-kit-daemon too.

> This should be unrelated, but do you have
> '-session        optional        pam_systemd.so'
> at the bottom of /etc/pam.d/kde* ? This is needed to get device ACL's
> to work, so would be nice if we could include it in the standard file
> (like is done for at least ssh and login).
Uh. I didn't know. If you say I should add it, I'll.


More information about the arch-dev-public mailing list