[arch-general] arch-general Digest, Vol 42, Issue 29

Keith grndrush at gmail.com
Sun Apr 20 14:41:50 EDT 2008


This might belong on the forums; I've been meaning to post on the topic for a while, but life gets in the way sometimes, and I see the topic here, so...

Karolina Lindqvist <karolina.lindqvist at kramnet.se>

> s?ndagen den 20 april 2008 skrev Stephen Wilkinson:

> > Does anyone have any suggestions as to why this may have stopped
> > working in moving from 2.6.23 to 2.6.24? Is it no longer possible to
> > run two sound cards together?  

> I got the same problem with my (only) built-in VIA sound chip. From kernel 2.6.24 and onwards, the chip has to be enabled in the bios.  I had it disabled before. Check your bios settings, and enable the card if it is disabled. Before linux ignored bios settings, but it look likes it does not do that anymore.

> Karolina

I have 2 ASUS mobo's: an A8V-MX, and a A8N-E. I first bought and built a system around the former (using Arch), maybe 2 years ago. Sound worked fine. It has an onboard Realtek ALC850, but I have an old PCI-based ESS Solo ES1938S card (ES1939 drivers worked fine) which has always provided superior performance to on-board chips (in 2-channel mode, at least, which is fine with me - I don't use my computer as an MP3-player; I only need sound for YouTube/Flash, etc). It has also worked with every system I've build the past 6 years or so.

Since the A8V doesn't have a PCI-E graphics slot, and I'd obtained an NVidia 6600GT, I bought the A8N and built a system around it (and the ES1939). No problem with sound.

8 months or so back, the A8N apparently burned up. It would start to boot, the do a full power reset, reboot, rinse and repeat. I couldn't even get to BIOS. I pulled everything out, including the 6600GT (used an old PCI S3 Virge DX for video). No change. I know it wasn't the P/S; I'm using the same P/S in the system I'm typing on ATM.

I rebuilt my system, using the A8V and my OLD GeForce2 MX 400. Worked fine - but no sound (using the ES1939). I finally pulled the ES1939 out, enabled the on-board sound chip. STILL no sound. This goes back 6-8 months, I try sound again with every kernel update; nothing's ever changed.

The manual which came (in the same, unopened box) with the A8V states the on-board sound chip is a Realtek ALC650; 'cat /proc/asound/cards' reports it as a 'ALC655'. 'lspci' reports a 'VIA VT8233/A/8235/8237 AC97 Audio Controller (rev 70)'. my rc.conf MODULES array:
'MODULES=(mii via-rhine ac97_bus snd-mixer-oss snd-pcm-oss snd-seq-oss snd-seq-device snd-seq-midi-event snd-seq snd-hwdep snd-page-alloc snd-pcm snd-rawmidi snd-timer snd snd-mpu401-uart snd-ac97-codec snd-hda-intel snd-via82xx soundcore)'

I don't understand why snd-mpu401-uart, snd-ac97-codec, snd-hda-intel, and snd-via82xx are ALL loaded, especially snd-hda-intel. That makes NO sense to me.

In addition to the ES1938S, I also have a SoundBlaster Live! Gold (CT4620) complete with a CT4660 Digital/MIDI daughter-card (which I don't need). I've re-installed Arch numerous times with and w/o the ES1938, SoundBlaster (with on-board sound disabled), and nothing seems to work.

I switched from KDE to Xfce4 a few weeks back (and like it), but would gladly return to KDE if I could get sound working. Any assistance would be greatly appreciated. I've spend MANY hours, read the wiki's, etc, with no progress whatsoever (note I DO get a 'hum' when I first plug in my speakers, but nothing after that). I would be happy with ANY of these hardware solutions, as long as I have sound.

All the appropriate entries in /dev/snd and /proc/asound are present, alsa is in my DAEMONS array in rc.conf.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://archlinux.org/pipermail/arch-general/attachments/20080420/51b57fdc/attachment.htm>

More information about the arch-general mailing list