[arch-general] Perhaps a bug on the dependences of KDE 4.2

Grigorios Bouzakis grbzks at gmail.com
Sat Feb 7 09:26:09 EST 2009

On Sat, Feb 07, 2009 at 10:12:02PM +0800, Christian Leng wrote:
> Greetings to all.
> Last night I tried to install KDE on my system. I had not had any
> version of KDE installed before.
> I simply used "pacman -S kde" to install the complete KDE from the
> REPO. Of course, "kde" was a package group:
>     [rookie at DROWNWESTLAKE ~]$ pacman -Qg kde
>     kde kdeaccessibility
>     kde kdeadmin
>     kde kdeartwork
>     kde kdebase
>     kde kdebase-runtime
>     kde kdebase-workspace
>     kde kdeedu
>     kde kdegames
>     kde kdegraphics
>     kde kdelibs
>     kde kdemultimedia
>     kde kdenetwork
>     kde kdepim
>     kde kdepimlibs
>     kde kdeplasma-addons
>     kde kdesdk
>     kde kdetoys
>     kde kdeutils
>     kde kdewebdev
> After the installation, I edited /etc/rc.conf and added the kdm to the
> daemons. Then I was desperated to find that KDM couldn't be launched
> correctly(but "startkde" worked well). A message box was displayed on
> the screen, saying "can't open file:
> /usr/share/apps/kdm/themes/archlinux-soft-grey". Then I searched the
> packages and installed the package 'archlinux-themes-kdm' and
> everything went well.
> It seems that the default kdm theme is set to 'archlinux-soft-grey'
> but the proper package can't be retrieved and installed automatically,
> i.e. a bug on the dependences of kde.

Whats the version of kdebase-workspace you have installed?
If its, see http://bugs.archlinux.org/task/13124
Wait for your mirror to sync and update to


what to do and what not to do in public :o)

More information about the arch-general mailing list