[arch-general] latest updates broke kde3, kde4, twm & console login ability

Rafa Griman rafagriman at gmail.com
Tue Jul 14 04:06:04 EDT 2009

Hi :)

On Tuesday 14 July 2009 09:43:24 David C. Rankin wrote:
> Listmates,
> 	Here is a rather strange one. On a dell gx280 box (Intel graphics) that
> had been running both kdemod3 and kde4.3 beta 2 just brilliantly, I am now
> left without any way to log in from the console. All was great until
> updates earlier today.
> 	What happens is -- the box boot fine and will bring up the kdm
> login/chooser display just fine. If kdm (from testing) is being used, then
> after supplying your user/pass all appears like it is going to start as
> usual. The Air theme is presented and the first little icon (I think it is
> a hard drive) fades in like usual. Then all of a sudden <BOOM> &%$ {BAM}
> !#$ <CRASH!!>, the screen goes black flickers slightly and then kdm
> restarts. (you could do this over-and-over all night)

Had this same problem once and solved it deleting the plasma config files in 
~/.kde. You can also try creating a new user and logging in with this new 
account to see if it works.

> 	The weird thing is that you CANNOT even choose "console login" to drop to
> text mode. Pretty much the same sequence plays out here to. After supplying
> your user/pass all appears like it is going to drop you to the text
> console, then the screen goes black and kdm restarts and you are left right
> back where you started -- Huh??
> 	Another bit of weirdness. When I edit my gurb config to tell it to just
> start in runlevel3 be adding a "3" at the end of the boot like, the boot
> process seems to ignore this. You see the "Entering Runlevel 3" line go by
> during boot, but then <WHACK> kdm starts and you are back at the beginning
> of the loop staring at the kdm greeter knowing this trick isn't going to
> work (Kinda reminds me of Groundhod Day -- the movie -- you remember)

Maybe you've added kdm to your DAEMONS line in /etc.rc.conf ;) Remove the kdm 
part in the DAEMONS line.

> 	So I have tried a pacman -Syu and loaded another 30 meg of packages, but
> none looking like they would solve the problem (and they didn't)
> 	Now I'm kinda at a loss What gives? What to check? But, how do I recover?
> (I still have full ssh access to the box, so fixing it won't be a problem
> once I can figure out what I'm looking for and how to fix it. Any help
> would be greatly appreciate it.

I'm also having issues with my intel gfx card on 3 laptops (Dell Latitude 
D610, MSI Wind and Acer ONE netbooks). When you hit Ctrl+Alt+F1 you get a VT 
but when you hit Alt+F7 you don't get the X (KDE 4.2 stable in my case) 
session back. This happens on all 3 laptops with Intel gfx card and latest 
updates :(

EXA acceleration, no UXA (can't get it to work properly: when you log out from 
KDE 4.2 stable it just hangs there with a black screen without fully logging 



"We cannot treat computers as Humans. Computers need love."

rgriman at skype.com
rgriman at jabberes.org

More information about the arch-general mailing list