[arch-general] Firefox on Arch - crash on exit

Tim Gelter tgelter at gurulabs.com
Mon Jul 20 00:48:00 EDT 2009

Hello listmates,

I'm hoping someone can shed some light on what's going on with Firefox.
While running arch (not ubuntu 9.04/fedora 11 which I also have
installed on the same laptop), I run into the following scenario nearly
every time I attempt to launch Firefox.

"Firefox is already running, but is not responding. To open a new
window, you must first close the existing Firefox process, or restart
your system."
Sure enough, I'm not being lied to:
$  ps -ef | grep firefox
tgelter  10871  4318  2 22:30 ?        00:00:02 /usr/bin/firefox
$  killall firefox && firefox
and I'm in business.

The thing is, it doesn't matter how I shut down Firefox (click the X,
file->quit, ctrl+w closing each tab until the last takes down Firefox),
I always end up in the same situation. I went to #archlinux on freenode
to talk about the issue a while back (this issue has been plaguing me
for weeks) and was told to try disabling extensions/themes, creating a
new profile and using that, "pacman -Rsn firefox && pacman -Sy
firefox"ing, I even got so fed up that I did a fresh install on a new
partition and tried again. Nothing has worked, at all. Following is my
info, I really doubt I'm the first person to run into this so please,
can anyone help?

arch x86_64 on a Lenovo T61 laptop (nvidia video card w/ proprietary driver)
x86_64 version of Firefox, x86_64 versions of jre/flash installed (this
is a must)
I run a kde 4.2.4 desktop installed from kdemod.
$  pacman -Sl | awk '{print $1}' | sort | uniq -c
   1900 community
    175 core
   1983 extra
    390 kdemod-core
     82 kdemod-extragear
     62 kdemod-playground
As you can see above, I don't have any testing/unstable packages
installed though there are some from extra & kdemod-playground.

If you need any other info, let me know. Remember this problem only
happens under arch, I have the same usage patterns and package
selections under Fedora/Ubuntu as far as I know.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 489 bytes
Desc: OpenPGP digital signature
URL: <http://www.archlinux.org/pipermail/arch-general/attachments/20090719/85d06502/attachment.pgp>

More information about the arch-general mailing list