[arch-general] PKGBUILD: depends and ranges of versions?

Magnus Therning magnus at therning.org
Thu Jun 4 17:30:48 EDT 2009

I couldn't find anything definitive on this.  Say I have a package A that 
depends on package B, but A can only be built against version 2.x of B (i.e. 
not against 1.x and not 3.x).  Is it allowed to do something like

     depends=('B>=2' 'B<3')


Magnus Therning                        (OpenPGP: 0xAB4DFBA4)
magnus@therning.org          Jabber: magnus@therning.org
http://therning.org/magnus         identi.ca|twitter: magthe

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: OpenPGP digital signature
URL: <http://www.archlinux.org/pipermail/arch-general/attachments/20090604/20a1b76c/attachment.pgp>

More information about the arch-general mailing list