[arch-general] Did new kernel version removed vesa FB?

Javier Vasquez jevv.cr at gmail.com
Tue May 12 12:28:04 EDT 2009

On 5/12/09, Damjan Georgievski <gdamjan at gmail.com> wrote:
>> I few minutes ago I upgraded a arch box (x86_64), and to my surprise,
>> something that was working before, loading the kernel with parameter
>> "vga=0x37D" is no longer working (nothing happens).  The new version
>> is  The resolution for nvidia quadro  fx 570m is
>> "1920x1200", but the nvidiafb module has never worked, so I need to
>> use the vesa FB...
> You can try uvesafb which should offer more features and maybe is even
> more stable.
> It's a module in the Ach kernel, so you'll need to include it in the
> initramfs ... Actually here's a description
> http://wiki.archlinux.org/index.php/Uvesafb
> --
> damjan

Well, I tried it, and I got uvesafb working (that's way better than no
FB at all), but I can't get it to work properly.  It seems uvesafb is
not paying attention to:

% grep '^options' /etc/modprobe.d/uvesafb
options uvesafb mode_option=1920x1200-32 at 75 scroll=ywrap

I've tried other resolutions, no frequency specification, and several
other combinations, and I always get:

uvesafb: NVIDIA Corporation, G84 Board - vb_040CE, Chip Rev   , OEM:
uvesafb: VBIOS/hardware doesn't support DDC transfers
uvesafb: no monitor limits have been set, default refresh rate will be used
uvesafb: scrolling: redraw
Console: switching to colour frame buffer device 128x48
uvesafb: framebuffer at 0xe7000000, mapped to 0xffffc20004100000,
using 14336k, total 14336k
fb0: VESA VGA frame buffer device

It doesn't sound completely right to me.  I also tried the default
1280x800, and nothing...  Well, with this I can set a terminus font,
which can't happen without FB...



More information about the arch-general mailing list