[arch-general] Did new kernel version removed vesa FB?

Damjan Georgievski gdamjan at gmail.com
Tue May 12 17:20:52 EDT 2009

> Well, I tried it, and I got uvesafb working (that's way better than no
> FB at all), but I can't get it to work properly.  It seems uvesafb is
> not paying attention to:
> % grep '^options' /etc/modprobe.d/uvesafb
> options uvesafb mode_option=1920x1200-32 at 75 scroll=ywrap
> I've tried other resolutions, no frequency specification, and several
> other combinations, and I always get:

You could try some of the options documented here:

        Force the use of VBE mode x.  The mode will only be set if it's
        found in the VBE-provided list of supported modes.
        NOTE: The mode number 'x' should be specified in VESA mode number
        notation, not the Linux kernel one (eg. 257 instead of 769).
        HINT: If you use this option because normal <mode> parameter does
        not work for you and you use a X server, you'll probably want to
        set the 'nocrtc' option to ensure that the video mode is properly
        restored after console <-> X switches.


More information about the arch-general mailing list