[arch-general] An amazing disk problem !

Nilesh Govindarajan lists at itech7.com
Thu Apr 1 21:31:22 EDT 2010


I'm having an amazing disk problem. My disk has LVM configured. /home 
and swap sits on LVM, while / is direct.

USELVM=yes is enabled in /etc/rc.conf and also it is there in 

The problem is that, sometimes when I boot, fsck complains that it 
wasn't able to find a ext2 superblock, and drops me to a sulogin shell. 
Now if I run fsck -vyf /home, it works. Even if fsck isn't run, it 
mounts properly using the command mount /home.

Now again when I restart, it will say the same thing or boot properly 
(seems like a random choice :D).

At last fed up, I issued the following commands at the sulogin shell:

mount -o remount,rw /
hostname Linux (yeah that's my hostname)
mount /home
init 5

And it worked successfully.

Any ideas about this AMAZING problem ??!?!?

Nilesh Govindarajan
Site & Server Administrator
मेरा भारत महान !
मम भारत: महत्तम भवतु !

More information about the arch-general mailing list