[arch-general] RAID 1 - Grub Problem / not finding stage1 file

b1 forum at b1online.de
Fri Apr 2 15:29:16 EDT 2010

Hello again

I finally got it working right now. The problem was mdadm using version
1.1 superblocks for the raid arrays. After forcing 1.0 superblocks it
worked. I ran into some other problems after that, but I was able to
handle them. The truth is, the wiki article is quite outdated. I am
planning to update it, this weekend.



On Fri, 2010-04-02 at 00:57 +0200, b1 wrote:
> Hello alltogether
> I am desperatly trying to get raid working. Currently I have Arch
> installed on /dev/sda and I would like to make an RAID 1 Array out of it
> (using /dev/sdb). I followed the guide from the wiki
> (http://wiki.archlinux.org/index.php/Convert_a_single_drive_system_to_RAID)
> and now I am stuck when I try to install grub on my newly created
> raid1-drive (Chapter 3.6 in the Wiki). Everytime I do a
> find /grub/stage1, grub only discovers the stage1 file on /dev/sda, but
> not the one on my raid-drive (/dev/sdb). I have tried this normally and
> from within the chroot environment, with no success. When I try to
> install the bootloader manually via 
> root(hd1,4)
> setup(hd1)
> grub gives the error 14: filesystem compatibility error.
> I have absolutly no idea, what I can do now. /dev/sdb5 is a ext2
> filesystem with type "Linux Raid Autodetect", containig all the
> necessary files (mounting the partition and doing an ls shows the stage1
> file).
> Any help on what I should do now is greatly appreciated
> Thanks
> Benedikt

More information about the arch-general mailing list