[arch-general] Problem with suspend

Csomay Mihaly list at csomay.hu
Fri Apr 2 02:59:38 EDT 2010

Philipp <hollunder at lavabit.com> writes:

> Excerpts from Csomay Mihaly's message of 2010-04-01 23:16:13 +0200:
>> Hi,
>> I'm configuring suspend/resume on an Acer 1810TZ, but I have a small
>> problem.
>> I already set it up to suspend when I close the lid, I modified
>> /etc/acpi/actions/lm_lid.sh to this:
>> #! /bin/sh
>> DISPLAY=:0 /bin/su csm -c "/usr/bin/i3lock -c 000044"
>> /usr/sbin/pm-suspend
> Wow, where can I read more about this?

About suspending when the lid is closed?

>> It works as expected, turns off the wifi, etc., restores fine when I hit
>> a button.
>> So I would think that running pm-suspend from a terminal would work
>> also, but it hangs on /usr/lib/pm-utils/sleep.d/98-smart-kernel-video.
>> If I move that file away, it suspends, but then the screen isn't
>> restored on resume, it's blank.
>> The worst part of it is that it worked from the command line once, but
>> back then I didn't know that hibernating with kms-enabled intel chips
>> results in memory corruption, and it killed my root partition so bad I
>> had to reinstall. And now it's not working. Any suggestions?
>> Thanks in advance.
> For me (on acer extensa 5220) pm-suspend and pm-hibernate (as root) work
> just fine, they did pre (intel) kms and they also do work fine with kms.
> I didn't need to do anything, so it seem quite strange to me.

So you don't experience this bug?

But back to my problem, does anybody know what could be the difference
between running pm-suspend from the command line and acpid running it
from a script in /etc/acpi/actions? I tried running it from X as root,
also with sudo, and also from a tty as root, no luck whatsoever.


More information about the arch-general mailing list