[arch-general] did my 4/10/10:pacman -Syu: destabilized e17's run command dialog??

Joe(theWordy)Philbrook jtwdyp at ttlc.net
Fri Apr 16 17:12:08 EDT 2010

Actually, I'm not sure if this is thanks to E17 itself or specific to 
Arch... And it's no big deal anyway because:
 A) e17 is "under heavy development", (And I know that means it's unstable)
 B) I've already got a workaround that works for me...
But I'd like to understand what happened a little better.

First you should know that I'm a multi-Linux/multi-boot kind of guy, and
that in every distro I install I depend on their package management system
to keep me out of dependency hel^Hck... ;-7 Of all my currently installed
distros, Arch is the one that seems most likely to install an unadulterated
upstream package, rather than a distro specific {modified} version. And e17
is definitely a "package" that I wouldn't even attempt to install by hand.
Thus the fact that the only e17 on my laptop that this has happened to is
the one in Arch, doesn't make it distro specific. It probably only means
the Arch e17 is more fully updated... At least that's mt best guess.

Anyway I'm not sure what the e17 version number that I installed to Arch
sometime since my mid March initial installation of Arch itself was, but as
of now the e17 help about lists it as "Enlightenment 0.16.999.063".
Prior to this recent pacman -Syu, e17's run prompt worked normally.
Afterwards it's become fussy what the first character I input into it is.
That is I usually start opera via the run prompt and when I type "o" the
command history displays the last instance of the command And I can in fact
start opera. I also use firefox, though I usually start that from inside
alpine. Today I tried to start firefox from the run prompt. But as soon as
I type an "f" into the first character position of the command input field,
I get a pop-up error telling me that "Enlightenment SEGV'd" That also
advises me to compile everything with "-g in CFLAGS" So far, the the restore
button succeeds in restarting e17 without closing any open applications...
But of course I didn't get firefox. I can start firefox from an xterm. And
I tested that I can type "of" into the run prompt without an immediate SEGV
But I can't type an f as the first character. I haven't tested the whole
alphabet, But I also can't type a command starting with "b" or "/" as the
first character. Though just because I'm stubborn I can tell you that I can
start firefox [via e17's run prompt] with: "~/../../usr/bin/firefox" (go figure)

I did say I've got a work around that works for me... I've also got XFCE
installed as a back-up desktop, so I've reassigned the keybinding I used to
pull up e17's run prompt with, to "/usr/bin/xfrun4". Which is works just

How can I a regular "Joe user", figure out if this is an actual E17 bug
or if it's an Arch specific thing???

|  ~^~   ~^~
|  <?>   <?>       Joe (theWordy) Philbrook
|      ^                J(tWdy)P
|    \___/         <<jtwdyp at ttlc.net>>

More information about the arch-general mailing list