[arch-general] starting network:fail[eth0 wasn't connected] How to enable without reboot?

Dan McGee dpmcgee at gmail.com
Tue May 18 14:53:34 EDT 2010

On Tue, May 18, 2010 at 1:45 PM, Joe(theWordy)Philbrook <jtwdyp at ttlc.net> wrote:
> Currently my pc is a laptop. I don't use a wireless interface. I
> connect to the Internet via cable broadband with a wired Ethernet
> connection and DHCP... This id very reliable. I can usually disconnect
> the laptop from the Ethernet cable and bring it into the livingroom
> for various offline use. Then when I bring it back to my desk, all I
> usually have to to is plug the Ethernet cable back in and wait a few
> seconds and the Internet will start to work again.
> BUT that is contingent on the Ethernet cable having been connected
> during boot up. So if for example I were to boot up my laptop in the
> livingroom where there isn't an Ethernet connection the boot process
> will delay at the point where it's screen message says its starting
> the network. Then it says it failed and continues setting everything
> else up.
> At this point, if I bring the laptop back to the desk, and plug in the
> Ethernet cable, it doesn't automatically connect. I tried:
> # ifconfig eth0 up
> but ping still doesn't find my ISP
> What am I missing????

Your dhcp process didn't start either, so you need to start one of
those. Something as simple as `dhcpcd -i eth0` might work.


More information about the arch-general mailing list