[arch-general] Problems suspending since 2.6.33

Michael Schaefer utf128 at googlemail.com
Tue May 25 19:14:37 EDT 2010

Hello guys,

since I upgraded for 2.6.33 several weeks ago, I encounter problems when
suspending (or more precisely waking up) my machine. Since everything
worked fine for month/years I first thought about a bug which might get
fixed soon but while 2.6.33 is pretty settled and I couldn't find
something in bug track I think the problem is somehow specific to my
As mentioned everything worked fine. I simply used 's2ram -f -p -m' to
suspend my machine (need the parameter due to my ATI graphics card).
No it seems suspending works fine but waking up crashes.
When waking the computer up the screens stay black. In addition the HDD
LED turns on for ~8sec and subsequent turns off. That's it. It seems
dead. Also "blind" commands have no effect...
I tried several parameter combination as well as pm-utils (which
error-free logs confirm my assumption that at least suspending works fine).
Also Xorg seems not to be the problem, since even suspending from a
blank tty (without xserver running at all) does not make the computer
wake up afterward.
Any ideas on this?

My machine:
Intel P35 Chipset
Intel Core 2 Duo E8400
ATI Radeon HD 3600

regards and thank you

More information about the arch-general mailing list