[arch-general] After the recent linux kernel update booting fails if usb disks are present in /etc/fstab

Hector Martinez-Seara hseara at gmail.com
Mon Jun 6 04:37:07 EDT 2011

for the last 4 days I've been again experiencing problems with my usb
disks at boot. Right now it is not as bad as before,  it fails around
75% of the boots which is still unacceptable. The problem was totally
solved with udev-168-2. But at some point, currently  udev-171-1,  the
problem was back. Sorry I can not be more precise as I don't boot the
system every day. Has been any changes again in this respect?

PD: I use the old thread so I don't have to explain again the problem
which is below detailed.

On 17 May 2011 14:19, Hector Martinez-Seara <hseara at gmail.com> wrote:
> Hi,
> After the last kernel update (I guess)  I cannot boot my system if a
> external usb disk is present in /etc/fstab. I use default fstab  mount
> options for the disks and they have each a single 1GB ext4 partition.
> Note that the disk mount okay when mounted from the command line after
> booting. Two identical disks has been tested with the same result so
> is not a hardware problem. The disks tested are two Western digital
> 1TB Essential Edition 2.0 (Model: wd10000h1u).
> In fact this problem was happening very seldom before (1 every 100
> reboots) due to to the waking up time of the devices but now it is
> every boot (only once worked). My question is: Has any thing changed
> regarding the usb at boot time lately in the kernel? In fact, I have
> notice a considerable speed up in the booting sequence up to the point
> where the file system checking is done. Maybe the changes to speed up
> the booting process have something to do with the problem I'm having?
> In my case it looks like nothing is been asked to my external drives
> when checking the filesystems at boot. Just after, the system fails
> claiming that it has not found the disks. In the past (two days ago),
> some activity in ligths and spining up sound was present when the
> system was checking the filesystems, but now everything is quiet.
> It is anybody else having the same problem?
> In the meanwhile, as I do not use this disk for booting I have add the
> nofail option to the fstab for the two disks. Now obviously everything
> works but the drives are not mounted. Does anybody know the best place
> to add the mount commands for the drives so they are always accessible
> for the users after boot?
> Thanks in advance,
> Hector
> --
> Hector Martínez-Seara Monné
> mail: hseara at gmail.com
> Tel: +34656271145
> Tel: +358442709253

Hector Martínez-Seara Monné
mail: hseara at gmail.com
Tel: +34656271145
Tel: +358442709253

More information about the arch-general mailing list