[arch-general] After the recent linux kernel update booting fails if usb disks are present in /etc/fstab

Tom Gundersen teg at jklm.no
Mon Jun 6 06:13:15 EDT 2011

On Mon, Jun 6, 2011 at 10:37 AM, Hector Martinez-Seara <hseara at gmail.com> wrote:
> t 4 days I've been again experiencing problems with my usb
> disks at boot. Right now it is not as bad as before,  it fails around
> 75% of the boots which is still unacceptable. The problem was totally
> solved with udev-168-2. But at some point, currently  udev-171-1,  the
> problem was back. Sorry I can not be more precise as I don't boot the
> system every day. Has been any changes again in this respect?

We have been speeding up boot with the recent udev releases, so any
race conditions will be more pronounced than before. There might of
course be a bug in udev which is not just a race, but then I would
need more info (like which exact version breaks for you, and maybe
have a try with [testing], as there is lots of news stuff there).

As I said before:

"That said, there is a fundamental problem with usb drives, so we
cannot reliably mount them at boot (it probably will work in practice
though). The problem is that there is no way to know when all usb
devices have been enumerated (even if the drivers are loaded), so we
don't know how long to wait before trying to mount them.

This is the kind of problems solved by systemd (in community), and it
is out of scope for the standard sysvinit initscripts (unless there is
a solution that I am not aware of)."

Another option, if usb is not actually needed for booting (as in your
case) is to have some software do automounting when the device appears
(KDE/GNOME can do this, I'm sure there are others too, but I'm not too
familiar with it).



More information about the arch-general mailing list