[arch-general] Display issues with Linux 3.1

hollunder at lavabit.com hollunder at lavabit.com
Sun Nov 13 13:10:56 EST 2011

> hollunder at ... wrote:
>>> hollunder at ..., Sat 2011-11-12 @ 22:42:57-0500:
>>> [1] https://bugs.freedesktop.org/show_bug.cgi?id=22674#c11
>> Thanks Taylor,
>> I still consider this a bug because this didn't happen for years but
>> seems to happen every time I boot since 3.1.
>> Another workaround is to disable kms by booting with the nomodeset
>> option.
>> Another new issue is that my mousepointer frequently
>> flickers/disappears and that xv video out in smplayer doesn't work
>> anymore, but both of those are with the nomodeset option, have yet to
>> test with kms enabled again.
> FWIW, KMS never worked for me (on a desktop, though).  The board has
> a nvidia chipset.  All the characters on the screen were displayed
> "giant mode", ie. I could see only the first few of them, but they were
> inches wide, with large pixels.
> So I had to append "nouveau.modeset=0" to the append line of the
> etc/lilo.conf.
> clemens

Back when kms was introduced it was already supported by intel (I guess
they developed it) and it took a while for nvidia and ATI. That it causes
issues now for intel is clearly a regression, that it still doesn't work
for nvidia is ... bad. On the other hand it seems a machine with intel
chip doesn't work properly without kms now, so I'm not quite sure what's

More information about the arch-general mailing list