[arch-general] No FFMPEG/LibAV for Audacity?

Martti Kühne mysatyre at gmail.com
Tue Nov 29 11:39:25 EST 2011

On Sun, Nov 27, 2011 at 04:46:59PM -0600, Jonathan E. Brickman wrote:
> >On 11/28/2011 12:34 AM, Jonathan E. Brickman wrote:
> >>I tried every combination of repo and AUR versions of Audacity, FFMPEG,
> >>and LibAV libraries, and I was not able to find a way to give Audacity
> >>the file named libavformat.so.52 which it wants to much.  So far as I
> >>have been able to tell, all of the versions of FFMPEG and LibAV either
> >>don't compile or produce libavformat.so.53, which the available versions
> >>of Audacity won't touch.
> >>
> >>Anyone have a solution?  I would try Ubuntu deb's, but I am concerned
> >>with introducing more conflicts instead of eliminating just one!
> >
> >have you actually tried to recompile audacity?
> >
> Yes, via AUR.  The AUR version recompiled fine, but in the
> preferences when run, it says that it is compiled without FFMPEG
> support.
> J.E.B.

Hey, you could have just pacman -S abs and executed the abs script. Then you
could have copied the directory in /var/abs/extra/audacity to the build folder
in your ~, which is preferably in ~/abs. In said directory there's a PKGBUILD
which lets you rebuild the exact [extra] package yourself. Source [1].


[1] https://wiki.archlinux.org/index.php/ABS

More information about the arch-general mailing list