[arch-general] netcfg wlan connection renewal

scrat baho-utot at columbus.rr.com
Wed Oct 12 16:44:14 EDT 2011

On 10/12/2011 02:43 PM, Philipp Überbacher wrote:
> Excerpts from Thomas Bächler's message of 2011-10-12 14:06:22 +0200:
>> Am 12.10.2011 12:54, schrieb Philipp Überbacher:
>>>> I'll also try the b43 driver again, but it didn't work for my
>>>> [14e4:4315] BCM4312 in the past. Guess it's worth a try though.
>>> So I enabled logging with -d but I don't understand the cause of the
>>> problem from this log (last 500 lines attached). To me it looks like
>>> the laptop gets disassociated, disconnects, scans again and fails with
>>> a timeout. My problem is that I don't know how it's supposed to work.
>> Which driver was this? The first thing I noticed is that the driver
>> gives reason 0 (no reason) for disconnecting (it isn't even reason 1,
>> which would mean "Unspecified"). After disconnecting, it fails to
>> receive any scan results. I am really out of ideas, but this looks like
>> a driver problem.
> This was with the broadcom-wl (proprietary), but today I tried with the
> b43 (free driver, but same proprietary firmware) with the same symptom
> but different log messages. The definitive difference is that it tries
> to scan over and over again. The log is full of that, so I've yet to get
> a reasonably useful portion out of that log. I'll try to start with a
> clean log tomorrow.
> I tried at home with my neighbors wlan where it worked for at least 45
> minutes (then he turned it off), but I don't yet know whether this was
> simply due to a longer leasetime or something similar.
> Does anyone know of a live-CD which contains those drivers? This way I
> could likely rule out a problem with Arch.
> I'll try to get a useful log tomorrow and maybe I can test some more
> with my neighbors wlan for comparison.

I am currently also trying to get a broadcomm working and the following 
may be of some use/value to you.


The broadcomm drivers where changed in kernel-2.6.37 and forward to 

It seems if you need to use the old b43 driver/firmware combo you will 
need kernel-2.6.36 or earlier.
  At least that is what I have came to.

The problem is I can't get the firmware for the new driver because 
git.kernel.org is down so I am unable to test. :(

More information about the arch-general mailing list