[arch-general] netcfg wlan connection renewal

Philipp Überbacher hollunder at lavabit.com
Wed Oct 12 17:55:25 EDT 2011

Excerpts from scrat's message of 2011-10-12 22:44:14 +0200:
> On 10/12/2011 02:43 PM, Philipp Überbacher wrote:
> > Excerpts from Thomas Bächler's message of 2011-10-12 14:06:22 +0200:
> >> Am 12.10.2011 12:54, schrieb Philipp Überbacher:
> >>>> I'll also try the b43 driver again, but it didn't work for my
> >>>> [14e4:4315] BCM4312 in the past. Guess it's worth a try though.
> >>> So I enabled logging with -d but I don't understand the cause of the
> >>> problem from this log (last 500 lines attached). To me it looks like
> >>> the laptop gets disassociated, disconnects, scans again and fails with
> >>> a timeout. My problem is that I don't know how it's supposed to work.
> >> Which driver was this? The first thing I noticed is that the driver
> >> gives reason 0 (no reason) for disconnecting (it isn't even reason 1,
> >> which would mean "Unspecified"). After disconnecting, it fails to
> >> receive any scan results. I am really out of ideas, but this looks like
> >> a driver problem.
> > This was with the broadcom-wl (proprietary), but today I tried with the
> > b43 (free driver, but same proprietary firmware) with the same symptom
> > but different log messages. The definitive difference is that it tries
> > to scan over and over again. The log is full of that, so I've yet to get
> > a reasonably useful portion out of that log. I'll try to start with a
> > clean log tomorrow.
> >
> > I tried at home with my neighbors wlan where it worked for at least 45
> > minutes (then he turned it off), but I don't yet know whether this was
> > simply due to a longer leasetime or something similar.
> >
> > Does anyone know of a live-CD which contains those drivers? This way I
> > could likely rule out a problem with Arch.
> >
> > I'll try to get a useful log tomorrow and maybe I can test some more
> > with my neighbors wlan for comparison.
> >
> I am currently also trying to get a broadcomm working and the following 
> may be of some use/value to you.
> http://wireless.kernel.org/en/users/Drivers/brcm80211
> The broadcomm drivers where changed in kernel-2.6.37 and forward to 
> brcmsmac/brcmfmac.

Thanks, but this doesn't apply to the chipset built into my laptop
(BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01). It only works with
either b43 or wl.

I just found this on http://wireless.kernel.org/en/users/Drivers/b43:

Known issues

    LP-PHY devices: DMA errors on some machines with kernel 2.6. Problem
    was fixed in 3.0. Using PIO (module param) can be used as workaround
    for 2.6. 

I suffered from this one, workaround didn't work, but it seems the fix
worked in my case.

> It seems if you need to use the old b43 driver/firmware combo you will 
> need kernel-2.6.36 or earlier.
>   At least that is what I have came to.

Nope, my chip does work, at least half an hour at a time at university.
It works with either broadcom-wifi-builder (broadcom-wl) or b43. But
only for half an hour at a time, then something happens.

> The problem is I can't get the firmware for the new driver because 
> git.kernel.org is down so I am unable to test. :(

It's up for me :)


More information about the arch-general mailing list