[arch-general] SOLVED: udev-174-1 problem (Re: [arch-dev-public] [signoff] udev-174-1)

Auguste Pop auguste at gmail.com
Thu Oct 27 04:55:41 EDT 2011

On Thu, Oct 27, 2011 at 4:24 PM, clemens fischer
<ino-news at spotteswoode.dnsalias.org> wrote:
> On Tue-2011/10/25-14:56 clemens fischer wrote:
>> My system broke with udev-174-1.  I have rules renaming eth* according
>> to their MACs for consistency, guarding against dependency on
>> order-of-detection, plus rules to customize a wlan running on an USB
>> device.  These rules didn't run.
> The initcpio (mkinitcpio(8)) on my homegrown initramfs image was
> udev-173, which didn't match the udev-174 in the "full" system.
> I didn't expect this, because I don't have any custom hooks or udev
> rules besides my "simple-atomatics" one, which is only one rule not
> interfering with anything else.  The initramfs is all archlinux, so to
> speak.
> Yesterday I compiled the new 3.0.8 stable kernel, and the script also
> invoked mkinitcpio(8), which eventually puts the new udev-174 into the
> initramfs image.  Thereafter the udev in the image and on the full
> system match, and my problem was gone  8-).
> clemens

have you tried manually run mkinitcpio?

More information about the arch-general mailing list