[arch-general] Nvidia Driver woes on Macbook 3,2

Daniel Bryan danbryan at gmail.com
Thu Dec 20 04:40:13 EST 2012

First of all, I'm sorry if the general discussion list isn't for questions
like this. I wasn't sure how to figure out what's appropriate.

Per https://bbs.archlinux.org/viewtopic.php?id=154496, I've had a real
ordeal trying to get video working on Arch on a repurposed late 2010
Macbook Air. I've never had issues like this with video / X in Arch before.

I'm wondering if anyone can give me a push in the right direction to at
least diagnose this problem. It's getting pretty hard to work without a

$ lspci | grep VGA
02:00.0 VGA compatible controller: NVIDIA Corporation MCP89 [GeForce 320M]
(rev a2)

Here's what I've tried in EFI mode:

   - all the proprietary drivers listed on the nvidia page on the Arch
   wiki; each of them either wouldn't load X or showed a blank screen;
   ctrl-alt-fN didn't work and I had to do a hard reboot
   - standard nouveau setup - X sort of starts up but there are weird
   artifacts, mouse doesn't work, and it freezes up pretty quickly.
   - nouveau with mesa-git  - as above
   - nouveau with mesa-full - above

I've also tried BIOS compatibility mode, but I wasn't able to get my drives
to mount. At any rate, it was very slow to boot, so I really want to stick
with the EFI + GRUB2 setup.

My Xorg.0.log when loading the proprietary driver, which just shows a black
screen: http://pastie.org/5556341

My Xorg.0.log when loading nouveau, which has strange artifacts, incomplete
rendering of windows, and soon locks up: http://codepad.org/QFdP9Fax

I have no .xinitrc file. For nouveau, I have the default X config. For the
proprietary drivers, I can nvidia-xconfig.

I've been trying everything both as a normal user and as root.

Video was working fine under OSX the day before I installed Arch so I don't
think it's the hardware.

I'm at a loss here and would appreciate any advice.



More information about the arch-general mailing list