[arch-general] Nvidia Driver woes on Macbook 3,2

Dave Reisner d at falconindy.com
Thu Dec 20 06:47:55 EST 2012

On Dec 20, 2012 6:27 AM, "Daniel Bryan" <danbryan at gmail.com> wrote:
> First of all, I'm sorry if the general discussion list isn't for questions
> like this. I wasn't sure how to figure out what's appropriate.
> Per https://bbs.archlinux.org/viewtopic.php?id=154496, I've had a real
> ordeal trying to get video working on Arch on a repurposed late 2010
> Macbook Air. I've never had issues like this with video / X in Arch

I know this creature... I used to own one. Used to.

> I'm wondering if anyone can give me a push in the right direction to at
> least diagnose this problem. It's getting pretty hard to work without a
> browser!
> $ lspci | grep VGA
> 02:00.0 VGA compatible controller: NVIDIA Corporation MCP89 [GeForce 320M]
> (rev a2)
> Here's what I've tried in EFI mode:
>    - all the proprietary drivers listed on the nvidia page on the Arch
>    wiki; each of them either wouldn't load X or showed a blank screen;
>    ctrl-alt-fN didn't work and I had to do a hard reboot

The proprietary nvidia driver cannot work in EFI mode -- it depends on the
bios being available for various parameters in locating the screen.

>    - standard nouveau setup - X sort of starts up but there are weird
>    artifacts, mouse doesn't work, and it freezes up pretty quickly.
>    - nouveau with mesa-git  - as above
>    - nouveau with mesa-full - above

This is actually progress based on bug reports I read a while ago and in
line with my previous comment. The *only* choice at the time was bios mode
with the nvidia driver.

> I've also tried BIOS compatibility mode, but I wasn't able to get my
> to mount.

Probably because in EFI mode, the sata disk uses native AHCI rather than
PATA compat (ata-generic and pata-acpi). You likely tried to use a auto
detect trimmed image which didn't have the proper modules. Using the
fallback image would have gotten you far enough to rebuild the pruned
initramfs with the right modules.

> At any rate, it was very slow to boot, so I really want to stick
> with the EFI + GRUB2 setup.
> My Xorg.0.log when loading the proprietary driver, which just shows a
> screen: http://pastie.org/5556341
> My Xorg.0.log when loading nouveau, which has strange artifacts,
> rendering of windows, and soon locks up: http://codepad.org/QFdP9Fax
> I have no .xinitrc file. For nouveau, I have the default X config. For the
> proprietary drivers, I can nvidia-xconfig.
> I've been trying everything both as a normal user and as root.
> Video was working fine under OSX the day before I installed Arch so I
> think it's the hardware.

Ah. But it is... Just not in the way you expect. Mac hardware is not off
the shelf hardware you find anywhere else. The nvidia 320M is an MBA only
device, and as such, drivers work best on OSX and only by luck elsewhere.

> I'm at a loss here and would appreciate any advice.

I'm afraid I have nothing positive to add. I ended up selling my MBA.

> Thanks,
> Daniel

More information about the arch-general mailing list