[arch-general] Ways to power on broadcom bcm4311 wireless adaptor without booting into windows

Vladimir Lomov lomov.vl at gmail.com
Thu Feb 23 03:07:03 EST 2012

** mercator [2012-02-22 23:35:26 +0800]:

> Hi guys,

> After switching from Linux Mint to Archlinux, my wireless card refused to
> show up in lspci. It DOES worked fine under Linux Mint, but .... Below is
> my output of 'lspci -vnn |grep Broadcom' :

> 10:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit
> Ethernet PCI Express (rev 02)

Sorry, if you find my answer a rude but did you use search engines? See
wiki.archlinux.org? E.g.

IMHO, proper command must be
$ lspci -vnn | grep 14e4

> My laptop is hp 6515b, with a touch panel for the toggle of wifi on/off
> etc. After a search in google I found the problem may be that the power of
> wifi has been shut down, and solution is to boot into windows and turn wifi
> on, because the touch panel will not work under Linux (as far as I know),

Ah, broadcom and HP (6515b), something familiar. I remember a problem
with HP notebook with broadcom wireless card about a year or two ago.
The problem was solved by downloading kernel module source compiling
then and installing (not Archlinux, Kubuntu).

This Google returns me for "broadcom linux bcm4311"


> And the I found a software named rfkill, hoping it will work. 'rfkill list'
> out put as follows :

> 0: hp-wifi: Wireless LAN
>         Soft blocked: yes
>         Hard blocked: yes

> After 'rfkill unblock all', I get:

> 0: hp-wifi: Wireless LAN
>         Soft blocked: no
>         Hard blocked: yes

> And still no wireless card detected. So my question is, is there any way to
> power the wifi on without booting into windows? (in fact, windows has
> diappeared from my laptop for 3 years, and there is no partition on my
> harddisk supporting windows install).

WBR, Vladimir Lomov

FORTRAN rots the brain.
		-- John McQuillin

More information about the arch-general mailing list