[arch-general] Ways to power on broadcom bcm4311 wireless adaptor without booting into windows

mercator mercator2006 at gmail.com
Thu Feb 23 05:25:34 EST 2012

Hi Vladimir,

In fact I've tried 'lspci -vnn | grep 14e4' before, and this is the output,
JUST one row:

10:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5787M
Gigabit Ethernet PCI Express [14e4:1693] (rev 02)

If I just type 'lspci' I will not find anything related to wireless card

About the kubuntu thing, did you mean this?


I've read it before open this thread. My problem is just the same as that
of stark222000: it's wifi card CANNOT be powered on, not that driver thing
listed in archwiki or linux wireless.

He solved it through booting into windows. But I don't have windows
installed and I don't want to install it anymore. So I opened this thread
as 'how to power on my wifi card' instead of 'my wifi card dose not work',
which will of course be classified as a driver issue.

And if I missed anything after my explanation, plz let me know. Thanks!

On Thu, 23 Feb 2012 17:07:03 +0900, Vladimir Lomov wrote:

> Hello,
> ** mercator [2012-02-22 23:35:26 +0800]:
> > Hi guys,
> > After switching from Linux Mint to Archlinux, my wireless card refused to
> > show up in lspci. It DOES worked fine under Linux Mint, but .... Below is
> > my output of 'lspci -vnn |grep Broadcom' :
> > 10:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M
> Gigabit
> > Ethernet PCI Express (rev 02)
> Sorry, if you find my answer a rude but did you use search engines? See
> wiki.archlinux.org? E.g.
> https://wiki.archlinux.org/index.php/Broadcom_wireless
> IMHO, proper command must be
> $ lspci -vnn | grep 14e4
> > My laptop is hp 6515b, with a touch panel for the toggle of wifi on/off
> > etc. After a search in google I found the problem may be that the power
> of
> > wifi has been shut down, and solution is to boot into windows and turn
> wifi
> > on, because the touch panel will not work under Linux (as far as I know),
> Ah, broadcom and HP (6515b), something familiar. I remember a problem
> with HP notebook with broadcom wireless card about a year or two ago.
> The problem was solved by downloading kernel module source compiling
> then and installing (not Archlinux, Kubuntu).
> This Google returns me for "broadcom linux bcm4311"
> http://www.broadcom.com/support/802.11/linux_sta.php
> http://linuxwireless.org/en/users/Drivers/b43
> > And the I found a software named rfkill, hoping it will work. 'rfkill
> list'
> > out put as follows :
> > 0: hp-wifi: Wireless LAN
> >         Soft blocked: yes
> >         Hard blocked: yes
> > After 'rfkill unblock all', I get:
> > 0: hp-wifi: Wireless LAN
> >         Soft blocked: no
> >         Hard blocked: yes
> > And still no wireless card detected. So my question is, is there any way
> to
> > power the wifi on without booting into windows? (in fact, windows has
> > diappeared from my laptop for 3 years, and there is no partition on my
> > harddisk supporting windows install).
> ---
> WBR, Vladimir Lomov
> --
> FORTRAN rots the brain.
>                -- John McQuillin

More information about the arch-general mailing list