[arch-general] CUPS not recognizing the printer

Squall Lionheart headmastersquall at gmail.com
Mon Jul 2 13:51:13 EDT 2012

> Greetings all,
> I have an HP LaserJet M1132 hooked via a USB port.
> It worked quite fine until my recent -Syu, where it suddenly stopped
> working. Since I had hplip upgraded, I assumed I have to reinstall the
> printer, so I removed it via the CUPS webinterface and right now I can't
> seem to get it installed again!
> Both CUPS and hp-setup fail to see it, however lsusb, dmesg and
> usb-devices clearly show it's there. The device node permissions are
> fine too. usblp is blacklisted, but I tried the installation after
> probing it, which didn't help.
> lpinfo -v stopped showing anything about USB.
> It doesn't seem that -Syu has something to do with it, since
> downgrading all the packages I've upgraded didn't help, I'm thinking
> this has something to do with the libusb -> libusbx transition earlier.
> Also tried the suggested solution to the same problem from here with no
> luck: https://bbs.archlinux.org/viewtopic.php?pid=1119424#p1119424
> Anyone can help?
> --
> Serge Hooge
> ()  ascii ribbon campaign - against html e-mail
> /\  www.asciiribbon.org   - against proprietary attachments

Not sure if this is related, but after my update this morning I am getting
this message in my CUPS configuration.  Searched the web and only found bug
report entry on the Ubuntu forms.  Not sure of a solution yet.

*"The PPD version (5.2.7) is not compatible with Gutenprint 5.2.8."
Yesterday is history.
Tomorrow is a mystery.
Today is a gift.
That's why its called the present.

Headmaster Squall :: The Wired/Section-9
Close the world  txen eht nepo
$3R14L 3XP3R1M3NT$ #L41N

More information about the arch-general mailing list