[arch-general] Huge log file for SLiM

Mikkel Kristiansen mester.kristiansen at gmail.com
Tue Jul 3 16:05:34 EDT 2012

Hi Sébastien
I have tried it once with SLiM, though the problem was that syslog-ng
wasn't placed in DAEMONS in rc.onf... So you could check that.

Sébastien Leblanc <leblancsebas at gmail.com> writes:

> Dearest Arch Linux Mailing List,
> So I was installing a few packages on a fairly recent Arch install,
> when I got an error message from pacman:
> --------8<--------8<--------8<--------8<--------
> : Retrieving packages from community...
> error: failed retrieving file '<package>' from <mirror1> : Failed
> writing body (1435 != 1448)
> error: failed retrieving file '<package>' from <mirror2> : Failed
> writing body (104 != 4344)
> error: failed retrieving file '<package>' from <mirror3> : Failed
> writing body (6 != 2896)
> warning: failed to retrieve some files from community
> error: failed to commit transaction (download library error)
> Errors occurred, no packages were upgraded.
> --------8<--------8<--------8<--------8<--------
> I immediately thought of a full hard drive. `df` reported that my /
> partition was full. My root FS partition is around 33G in size: that's
> not huge, but since it is a fairly recent install, I thought there was
> no way it could be normally that full.
> I ran `du -sh` on things in my / drive, and it reported that /var/log
> was using up 27G of space. The culprit was SLiM's log: it was making
> up 99.99394 of all the space occupied by logs on my system. For some
> reason, log rotation does not occur with SLiM on my system. All other
> applications with logs work fine.
> Is anyone having this issue?
> I could not test it on other systems as it is the only one I have running SLiM.


More information about the arch-general mailing list