[arch-general] problems with wifi b43 (broadcom)

Leonidas Spyropoulos artafinde at gmail.com
Sat Jul 14 17:59:29 EDT 2012

On Sat, Jul 14, 2012 at 10:14 PM, Jesse Juhani Jaara
<jesse.jaara at gmail.com> wrote:
> la, 2012-07-14 kello 21:54 +0100, Leonidas Spyropoulos kirjoitti:
>> I can't seem to be able to get an IP. I am including the logs as well.
>> I tried disabling the ipv6 with no luck (so I revert it).
>> I tried with a usb wifi card and it's working fine.
>> Any suggestions?
> How did you try to get the ip? dhcpcd? Does manually setting ip wok?
> Also you need to paste the logs into the message or some pastebin
> service, Arch's mailing lists stip out any attachments

I am using dhcpd and it's working because against the same router the
usb wifi card works.
Also I had some progress:
I managed to configure and make the Broadcom card work with
broadcom-wl drivers (propretiery)
According to the wiki
(https://wiki.archlinux.org/index.php/Broadcom_wireless) though this
is not recomended and I would prefer to use the b43 driver.

my kernel messages can be found here:

I assume that dhcpd daemon works fine because on all other interfaces
(and even on the wlan0 with wl driver) works fine.
I used the firmware from AUR.

Caution: breathing may be hazardous to your health.

#include <stdio.h>
int main(){printf("%s","\x4c\x65\x6f\x6e\x69\x64\x61\x73");}

More information about the arch-general mailing list