[arch-general] login fails after update

Fons Adriaensen fons at linuxaudio.org
Mon Jul 16 07:02:15 EDT 2012

On Mon, Jul 16, 2012 at 12:20:10PM +0200, Tom Gundersen wrote:
> On Jul 16, 2012 12:17 PM, "Fons Adriaensen" <fons at linuxaudio.org> wrote:
> >
> > On Mon, Jul 16, 2012 at 04:42:28AM +0100, Dave Morgan wrote:
> >
> >
> > > The most likely reason for /bin/login being missing is that the upgrade
> > > was forced.
> >
> > No, it was not. As already said I followed the instructions
> > which clearly stated not to use --force.
> I have no idea how this happened, but reinstalling util-linux should fix it.

I completely new netinstall fixed it :-).

Maybe the system was just too old, it was the only one not kept
up to date.

Since the latest core install image (about 11 months ago), there
have been several changes that required a manual intervention
during a routine update, the /lib thing is just the latest one.
Each of them was clearly announced and documented, and usually
involved upgrading some packages separately either before the
rest, or after it using --ignore first, and at least in one
case using --force was the recommended way to go. Each of these
upgrades worked well separately and were no big deal for anyone
using Arch for some time.

But imagine the situation of a new user who has just done a core
install, and is told to do -Syu after the first reboot, facing
all these manual steps together. I don't think you can expect
such a new user to do the right thing, if it is possible at all.
Which is not a good thing for Archlinux' name and fame. I suspect
we need new install images ASAP.



A world of exhaustive, reliable metadata would be an utopia.
It's also a pipe-dream, founded on self-delusion, nerd hubris
and hysterically inflated market opportunities. (Cory Doctorow)

More information about the arch-general mailing list