[arch-general] [Solved] Re: pacman and corrupt packages

Shridhar Daithankar ghodechhap at ghodechhap.net
Thu Jul 26 00:07:38 EDT 2012

On Wednesday 25 Jul 2012 11:15:48 AM Krzysztof Warzecha wrote:
> 2012/7/25 Ike Devolder <ike.devolder at gmail.com>:
> >> That is an option I have not yet tried but I just want to preserve the
> >> reproduction and debug the problem if there is any.
> Maybe this will help:
> cd /var/lib/pacman/pkg
> for pkg in *; do bsdtar -tf $pkg > /dev/null || echo "$pkg is broken"; done
> This is strange, for me, pacman always showed which package is broken
> (and asked to delete it). Can you disable any ftp mirrors from your
> mirrorlist ([1])? Could you post your pacman.conf?
> [1] https://bbs.archlinux.org/viewtopic.php?pid=1050214#p1050214

Ok, that did the trick.

Last package I was getting error for was gcc-libs. So I removed it from cache.

Then I searched the cache for broken packages, as suggested above and found 
icu package which wasn't completely download i.e. only a .xz.part file, not a 
.xz file.

Removed that and pacman -Syu. It worked.

I also have another i686 VM for $DAYJOB(I am not letting some closed source 
vpn solution take over my desktop network :P ) and it had the same problem.

So I checked up the part files there and found qt-4.8.x...part. Removed it and 
it worked there as well.

I am going to reproduce this problem next time by forcefully interrupting a 
download(if my ISP does not beat me to it already) and file a bug.

Thanks for all the help :)


More information about the arch-general mailing list