[arch-general] Totem segfaulting on start on a fully up-to-date archlinux with testing enabled.

Vladimir Lomov lomov.vl at gmail.com
Sat Jun 16 09:50:22 EDT 2012

** solsTiCe d'Hiver [2012-06-16 13:24:34 +0200]:

> Le samedi 16 juin 2012 à 19:36 +0900, Vladimir Lomov a écrit :
>> IMHO, the minimal steps to use new NVIDIA driver are
>> 1. shutdown X system;
>> 2. logout as usual user and login as root;
>> 3. unload nvidia (kernel) module;
>> 4. load new nvidia (kernel) module;
>> 5. start X system.

> Are you sure you don't need to run some udev related command like
> udevadm ?

> Because last time I tried something like you said it didn't work

Don't know you environment and hardware, but I just tried:

on my desktop: Archlinux x86_64 (AMD), kernel 3.4.2-2, systemd; last
update brought nvidia 259.59 when I was running openbox. I installed
update, logout (exited Openbox) which should be bring me to KDM but
I got a terminal. I logged into terminal as a user, run
$ sudo systemctl stop kdm.service
$ sudo modprobe -r nvidia
$ sudo modprobe nvidia
$ sudo systemctl kdm.service
so now all works fine.

>From /var/log/Xorg.0.log:
$ grep 'NVIDIA GLX' /var/log/Xorg.0.log
[ 47278.388] (II) NVIDIA GLX Module  295.59  Wed Jun  6 21:40:44 PDT 2012

WBR, Vladimir Lomov

Cinemuck, n.:
	The combination of popcorn, soda, and melted chocolate which
	covers the floors of movie theaters.
		-- Rich Hall, "Sniglets"

More information about the arch-general mailing list