[arch-general] makechrootpkg - howto run 'pacman-key --init'?

Magnus Therning magnus at therning.org
Tue Jun 19 16:48:03 EDT 2012

On Tue, Jun 19, 2012 at 03:13:52PM -0500, David C. Rankin wrote:
>On 06/18/2012 11:05 AM, Magnus Therning wrote:
>>I've been running into this lately too and the only way I could think
>>of was to manually chroot and run the commands myself:
>>  % sudo mkarchroot -r /bin/bash path/to/my/root
>Thanks Magnus!
>Looks like the Arch wizards solved this in the updates today.
>Created a new chroot mkarchroot V2 and kicked off the trinity build
>in the chroot with gcc 4.7.1 and it is churning away. So from what I
>can tell, all issues are solved. I didn't have any pacmankey --init
>issues and all ioctl device errors are gone.

That's great to hear, then I can stop worrying about any issues for
new users of the build-in-chroot scripts used to build [haskell] :-)


Magnus Therning                      OpenPGP: 0xAB4DFBA4 
email: magnus at therning.org   jabber: magnus at therning.org
twitter: magthe               http://therning.org/magnus

I invented the term Object-Oriented, and I can tell you I did not have
C++ in mind.
     -- Alan Kay
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://mailman.archlinux.org/pipermail/arch-general/attachments/20120619/f0dc0e73/attachment.asc>

More information about the arch-general mailing list