[arch-general] unable to boot up

Thomas Rand tom at tomsbox.co.uk
Thu Nov 1 09:31:13 EDT 2012

Hey Archers,
my issue begins with me trying to patch vmware for 3.6.3-1-arch
I tried using vmware & this told me the modules were not present for
3.6.3 so I went to grab latest from AUR (vmware-patch), the comments
on there suggested that the ones for 3.5.x still worked but needed to
be rebuilt.

so I read these instructions:
https://wiki.archlinux.org/index.php/VM … stallation

I noticed that in the finishing up section it gave a warning that if I
update the kernel need too issue the following:

vmware-modconfig --console --install-all

so I ran this & tried to run vmplayer
this opened but crashed as soon as i tried to play a VM, I then
decided that as I had not used it for some time I would just remove

vmware-installer --uninstall-product vmware-player

this finished & so I ran:

pacman -R vmware-patch

all was ok (so I thought) a while later I had to reboot to do
something in my win7 install (non volatile) upon completing I rebooted
back to arch & now my install refuses to boot & I see:

Failed to start load Kernel Modules [FAILED] see 'systemctl status
systemd-modules-load.service' for details

obviously systemd fall's over & offers to enter password or control-D
to continue

well the system refuses to go any further & locks up totally (no
flashing kbd lights like a panic though!)
the exact same happens when I boot the fallback kernel

I can chroot into it using the old media (CORE 2011.08.19) which is
the most recent I have, whilst chrooted in I thought perhaps the old
vmware modules did not get removed correctly so I blacklisted them in:


blacklist vmmon

I have managed to get into the system using the following boot parameter:


I then ran:

systemctl status systemd-modules-load.service

this provided the default message about the service not starting but
no reason why or what caused it to fail

So any advice or way forward would be appreciated as I am totally lost
& have googled everything I can think of which may help but this is
the first time I have b0rk3d the modules & am lost as to what to do.

Thomas Rand

More information about the arch-general mailing list