[arch-general] unable to boot up

Tom Rand tom at tomsbox.co.uk
Fri Nov 2 06:24:54 EDT 2012

the initial issue was caused by systemd trying to load cdemu kernel module 
which was removed by vmware!
once i removed the .conf file from /etc/modules.d/ normality crept back BUT
 my nic was not being initialised as the r8169 was refusing to load.
I then assumed most of my modules were corrupted some how hence why they 
were failing to load (even modprobe was failing), a possibility that me 
running vmware-modconfig [...] as stated in my initial post caused this
but i have no way to disprove or prove this but i resolved this by 
re-installing the kernel & headers.

thanks for time taken in reading this.

On Thu, Nov 01, 2012 at 03:31:13PM +0200, Thomas Rand wrote:
> Hey Archers,
> my issue begins with me trying to patch vmware for 3.6.3-1-arch
> I tried using vmware & this told me the modules were not present for
> 3.6.3 so I went to grab latest from AUR (vmware-patch), the comments
> on there suggested that the ones for 3.5.x still worked but needed to
> be rebuilt.
> so I read these instructions:
> https://wiki.archlinux.org/index.php/VM … stallation
> I noticed that in the finishing up section it gave a warning that if I
> update the kernel need too issue the following:
> vmware-modconfig --console --install-all
> so I ran this & tried to run vmplayer
> this opened but crashed as soon as i tried to play a VM, I then
> decided that as I had not used it for some time I would just remove
> it:
> vmware-installer --uninstall-product vmware-player
> this finished & so I ran:
> pacman -R vmware-patch
> all was ok (so I thought) a while later I had to reboot to do
> something in my win7 install (non volatile) upon completing I rebooted
> back to arch & now my install refuses to boot & I see:
> Failed to start load Kernel Modules [FAILED] see 'systemctl status
> systemd-modules-load.service' for details
> obviously systemd fall's over & offers to enter password or control-D
> to continue
> well the system refuses to go any further & locks up totally (no
> flashing kbd lights like a panic though!)
> the exact same happens when I boot the fallback kernel
> I can chroot into it using the old media (CORE 2011.08.19) which is
> the most recent I have, whilst chrooted in I thought perhaps the old
> vmware modules did not get removed correctly so I blacklisted them in:
> /etc/modprobe.d/vmware.conf
> blacklist vmmon
> [...]
> I have managed to get into the system using the following boot parameter:
> systemd.unit=rescue.target
> I then ran:
> systemctl status systemd-modules-load.service
> this provided the default message about the service not starting but
> no reason why or what caused it to fail
> So any advice or way forward would be appreciated as I am totally lost
> & have googled everything I can think of which may help but this is
> the first time I have b0rk3d the modules & am lost as to what to do.
> -- 
> Regards
> Thomas Rand

More information about the arch-general mailing list