[arch-general] Bind mount /dev from fstab with systemd

Mauro Santos registo.mailling at gmail.com
Mon Sep 24 14:55:39 EDT 2012

I've been trying to (r)bind mount /dev from fstab and it is failing for
some reason that I can't figure out.

I have tried to mount it on demand, only when accessed, since the chroot
where I need it is not used very often, to try and achieve that I've
tried the following line in fstab:

/dev /path/to/chroot/dev none rbind,noauto,x-systemd.automount 0 0

This didn't work, trying 'ls /path/to/chroot/dev' seems to hang forever
and the output from journalctl says:

systemd[1]: Job dev.device/start timed out.
systemd[1]: Job extra-chroot-centos-dev.mount/start failed with result
systemd[1]: Job dev.device/start failed with result 'timeout'.

I have also tried mounting it on boot using:
/dev /path/to/chroot/dev none rbind 0 0

Which also doesn't work and makes the boot process stop, the machine is
still responsive to ctrl-alt-del and reboots cleanly but there is no
indication of why it stops.

Bind mounting /proc and /sys when accessed works fine, also mounting
manually with 'mount --rbind /dev /path/to/chroot/dev' works
just fine, I am out of ideas and google doesn't know either, any tips or
pointers are welcome.

Mauro Santos

More information about the arch-general mailing list